Ip whitelist does not have effect

I am trying to access my account status and I am always getting APIError(code=-2015).
This only works when I disable the Ip restrictions.

I have found this other topic pretty similar: IP restriction not working.
Thus, I used the python script spot.py (from binance-exchange/binance-signature-examples) and I get the same results. This only works by disabling the Ip restrictions.

Is there any specific format in the Ips? This is the format I am using: 192.168.X.Y
I am giving the IPv4 address. I have double checked all this in Microsoft support (https://support.microsoft.com/en-us/windows/find-your-ip-address-f21a9bbc-c582-55cd-35e0-73431160a1b9)

I have tried both Ethernet cable connection and Wifi connection by adding both resulting Ips to the whitelist without luck.

There is no VPN or proxy.


You need to confirm the IP you used to access binance. The most affirmative way is enable your futures account and API key to give it another run to any fapi* endpoint. It would give you the IP you’re using to access binance server.

Thanks @MJW. I used https://www.whatismyip.com/