[testnet] The counterparty's best price does not meet the PERCENT_PRICE filter limit

Getting this error when submitting MARKET orders :

{"code":-4131,"msg":"The counterparty's best price does not meet the PERCENT_PRICE filter limit."}

Also, LIMIT orders not getting filled (even placing from WebUI).

Is testnet operating correctly? How do I go about testing API endpoints if testnet ghosting like this?

I’m afraid it’s caused by no liquidity from the testnet. Would you like to try with another symbol with more open orders?

I’m getting the same error while trading in testnet USD-M futures. I tried to trade a lot of coins and I think I can trade only BTCUSDT (some of coins give me error “unable to fill”). Other coins even have different price in testnet and product (why?). I need to test my program and testing it using product balance is so wasteful for me. So how can I use testnet to test my program?

Do you have been got this error in production environment?

In Testnet I had this problem several times, and really worries me. I mean, if in testnet I got liquidty problems, I don’t want to risk my money in production placing orders that never will get filled.

Hey bro Idk if your are still facing the issue, actually I recently face this issue in Testnet, I was wondering where the problem is… The mistake I was making was that I selected wrong pair, by wrong pair I mean that i was trying to trade in LUNC/BUSD , while on testnet i had USDT not BUSD… Select USDT pair like BTC/USDT, and it will work, hope your problem will be solve, thanks.

Yes! It’s really frustrating. I just need to check some diffs between one-way & hedge modes, but I cannot close my only position due to this error((( And I cannot to switch mode to desired due to open position I have. The only way to create another account for testnet