reduceOnly not working on binance futures


I’m using python-binance api currently.

I am trying to place market sell order of BTCUSDT with 0.05 qty. and also place limit reduce only sell order for the same pair and qty.

Here are my code.

bodata = client.futures_create_order(symbol=“BTCUSDT”,type=‘MARKET’,side=“SELL”,quantity=0.05,recvWindow=“60000”)
sodata = client.futures_create_order(symbol=“BTCUSDT”,type=‘LIMIT’,timeInForce=‘GTC’,price=20600,recuceOnly=“true”,side=“BUY”,quantity=0.05,recvWindow=“60000”)

Here is my output:

{‘orderId’: 3276861113, ‘symbol’: ‘BTCUSDT’, ‘status’: ‘NEW’, ‘clientOrderId’: ‘M9HxVkOgySg8QnWUyvW6d1’, ‘price’: ‘0’, ‘avgPrice’: ‘0.00000’, ‘origQty’: ‘0.050’, ‘executedQty’: ‘0’, ‘cumQty’: ‘0’, ‘cumQuote’: ‘0’, ‘timeInForce’: ‘GTC’, ‘type’: ‘MARKET’, ‘reduceOnly’: False, ‘closePosition’: False, ‘side’: ‘SELL’, ‘positionSide’: ‘BOTH’, ‘stopPrice’: ‘0’, ‘workingType’: ‘CONTRACT_PRICE’, ‘priceProtect’: False, ‘origType’: ‘MARKET’, ‘updateTime’: 1674128770788}

{‘orderId’: 3276861114, ‘symbol’: ‘BTCUSDT’, ‘status’: ‘NEW’, ‘clientOrderId’: ‘ifb9kSfUoA2oClNB5OT4Xq’, ‘price’: ‘20600’, ‘avgPrice’: ‘0.00000’, ‘origQty’: ‘0.050’, ‘executedQty’: ‘0’, ‘cumQty’: ‘0’, ‘cumQuote’: ‘0’, ‘timeInForce’: ‘GTC’, ‘type’: ‘LIMIT’, ‘reduceOnly’: False, ‘closePosition’: False, ‘side’: ‘BUY’, ‘positionSide’: ‘BOTH’, ‘stopPrice’: ‘0’, ‘workingType’: ‘CONTRACT_PRICE’, ‘priceProtect’: False, ‘origType’: ‘LIMIT’, ‘updateTime’: 1674128770954}

What I’m doing wrong?

I’m not familiar with the library you are using. It’s possible that the parameter was not actually sent to server.

You may try to test it in this simple python script. It will print out the exact parameters sent to the server.