GET /sapi/v1/staking/position suddenly started to return code -1000 on page 1

Hi Everyone,

Today the staking/position api started to return code -1000 for one of my calls, the same call worked fine for months and I think it’s something related to my account, since with parameters:

product=STAKING&size=100 → code -1000
product=STAKING&size=100&current=2 → still works fine.

Yes, I have more than 100 positions and I receive the results for the page 2 just fine.

I noticed that today I had 2 staking auto renews, but that happened before without any issues.

Can the devs please check?


Hello, I have experience a similar problem and decide to investigate what workaround would be and seen that once the data received passes 47 contracts the system returns a -1000 error (either by setting the “size” param to >47 or utilizing the “current” >47) thus it permits me only to view my last 47 staking products that I have subscribed to. Mixing-and-matching “size” and “current” does not produce a longer list of staking products subscribed. Hope that this information is useful to the devs. (although the size is different from the one posted)

—EDIT{1}— : I have dug deeper in to the problem: As I know what assets I have subscribed to I tried to get them individually by setting the “asset” parameter and observed that: I can utilize the API to the described maximums (normal params) for all assets BESIDES one: CHR (chromia), for which I can´t even get anything (causing the -1000 error). If a dev contacts me I would be glad to give the list of all assets I tried (as to not make them public), I hope that this helps solve the problem faster.

—EDIT{2}— I have lowered the “size” to 1 and looped through “current” to see which contract was the one causing the problem with the “asset”:“CHR” and managed to get staking products until the error (-1000) was produced at: staking product CHR*90, subscribed at 2022-09-04, by auto. (hope that this is useful)

Unfortunately we can’t reproduce this issue, please contact the Customer Support and see if they can help to review the account.

Hi Dino,

Since the staking api is relatively new, maybe I can send a read/only api/secret to your team, so the problem can be easily reproduced? I think the issue is related to have too many entries or something like that.

I don’t think the binance support can help with that api issue, since my account is fully functional and to test it, I even did one small staking today.

Thanks for your input.

You shouldn’t share API key/secret with anyone, it may lead to great risk to your account.

Please feel free to contact Customer Support, they may find more details on your account. You can share this topic with them, which may be helpful for them to understand the context.

Hey Dino,

Sorry to insist, but after some testing today, I could determine exactly the culprit:

If I call the /sapi/v1/staking/position with size=4, the api runs fine, but if I run the api from size 5 onwards I receive the code -1000 like I said before.

So, since the record order of that api is the same of sapi/v1/staking/stakingRecord that is working fine, I could determine that a PARTIAL auto renewed position on CHR for 90 days caused the issue.

It’s partial because binance changed the QUOTA for CHR*90 on the fly and the rest of my position got “kicked out” to the spot.

Here are some details of the problematic record:

I could also confirm that issue adding the asset paremeter to the staking/position api, where the error only happened with the CHR.

Maybe due that partial auto renew the project changed or something like that causing the issue, please take a look since It’s a likely a bug on the staking/position api.

Hello there, As I have mentioned in the comment above; I have tried to identify the problem in more detail:

TL-DR : One staking contract purchased on 2022-09-04 by auto for product CHR*90 is causing the -1000 error (at least for me). I recommend checking all individual products that are subscribed (by incrementing the “current” parameter) using “asset”:X, “size”:1, “current”: 1 to identify which purchased product is the one causing the problem.

----Firstly: I have made requests that incremented over the parameter “size” starting at 1 and going to 100 and yielded a problem at numbers greater than 47 (with “current” set 1; then performed the increment over parameter “current” using “size”:1, and yielded the same problem (error -1000 at “current”:47).

----Secondly: I have requested each individual asset subscribed {“size”:100, “current”: 1(till end)}(all of which worked besides one: “CHR”)

----Thirdly: incrementing the “current”(starting at 1) parameter while maintaining “size”: 1 and “asset”:“CHR” produced an error at a specific purchased product “CHR*90” (bought at 2022-09-04, checked through the app). Now knowing what “current” value was the offending one I have jumped over it (by starting the “current” parameter +1 from the one that cause the problem) and check all the rest of the purchased staking products and non produced the error(-1000).

Hope this helps the dev team figure out where the problem lies.

Best regards,

Yep, seems that Binance changing the quota for CHR*90 mid game caused the issue with staking/position api when the auto renew occured, it’s exactly what happened with me as I described on my last answer, let’s hope @dino can fix it!

Lets hope so; I left the step-by-step workaround in the hopes that others might identify other contracts that are at fault (not that I know of), increase the likelihood of reproducing the issue and help the developers get to the bottom of this. More power to you @dino .

The issue is now fixed, I don’t know if they changed anything on the api, but it coincidentally started working again after the “Simple Earn” implementation by Binance.