GET /sapi/v1/pay/transactions returning data [] always

Hello,

I am using the GET /sapi/v1/pay/transactions endpoint to retrieve trading transactions for the last couple of months. I tried different intervals (long via unix as seen in your .net library GitHub - binance/binance-spot-api-docs: Official Documentation for the Binance Spot APIs and Streams) but I always get no results in return. The call seems to be going through successfully though.

The response is {“code”:“000000”,“message”:“success”,“data”:,“success”:true}. Is this related to API access or is this a bug? I am using an API Key with reading access.

Hello,
Unfortunately I’m not able to test Pay endpoint, although can you try with with our GitHub - binance/binance-api-postman: Postman collection for Binance Public API, including spot, margin, futures, etc. and share what’s returned from there, please?

Hello, sorry for the late response.

I downloaded and tried out your postman API. I get a "Service unavailable from a restricted location according to ‘b. Eligibility’ error though. Trying this out from Germany, IP-restricted api/secret which currently works from within my project (just still not getting the expected result from the endpoint-under-question). I think it is an API error though, as I get the same result even with a non working / random key/secret combination.