Create order not all sent parameter were read; code -1104

Im trying to create order
/api/v3/order/test?symbol=XRPBTC&side=SELL&type=LIMIT&timeInForce=GTC&quantity=5&price=0.00002505&timestamp=1608367596542&signature=c078ffa6ce3d85489382674854c0bdc79fb370d412958f46f4d9a0715e7dd226

And received error
{
code: -1104,
msg: “Not all sent parameters were read; read ‘8’ parameter(s) but was sent ‘9’.”
}

Whats wrong?

I’m having the same issue.

I’m using code directly from the github docs
/binance-us/binance-official-api-docs/blob/master/rest-api.md#account-endpoints

Powershell:

Invoke-WebRequest -Uri $URLOrder -H $header -Method Get;

My called URL

https://api.binance.us/api/v3/order?symbol=LTCBTC&side=BUY&type=LIMIT&timeInForce=GTC&quantity=1&price=0.1&recvWindow=5000&timestamp=1610904168760&signature=5fb799a0d6e51353cdc605b80ecb50b5b90b243a2db0d49613e15137dd8896b4

or

https://api.binance.us/api/v3/order?symbol=ETHUSD&side=SELL&type=LIMIT&timeInForce=GTC&quantity=0.01&price=1100.01&recvWindow=3000&timestamp=1610904210528&signature=e87793461880812b57527efda236ea3e5254f34d0844f41db27f24c1a34d98c6

return:

"code":-1101,"msg":"Too many parameters; expected '6' and received '9'."

Can you help??

Re-reading @Simple_Development
I changed my command to

$ret = Invoke-WebRequest -Uri $URLOrder -H $header -Method Post;

The parameters in the request looks good, do you have another parameter sent in the body?

Hey @Simple_Development. Could you resolve your problem?
I created this order and got the same error:

timestamp=1610304953692&recvWindow=5000&symbol=BTCUSDT&type=MARKET&side=BUY&newOrderRespType=FULL&quantity=1&created=1610252280000&signature=cd844d4cfa22881df4ea5fbb1be20a70986fde9aae1e709aa89b262f0cf85cbe

Hi, yes i resolved problem. I did send POST request and pass params in request body. Works fine. But query params doesnt work yet. Support cannot help me.

For POST, PUT, and DELETE endpoints, the parameters may be sent as a query string or in the request body with content type application/x-www-form-urlencoded. You may mix parameters between both the query string and request body if you wish to do so.

@aisling what an excellent find!!! Stupid me! Thank you so much, my hair will be eternally thankful that you prevented it from turning grey more than necessary. :slight_smile:

Now I’m fighting a “LOT_SIZE” error when I want to sell all LSK in my account, but I hope that I’ll be able to solve that…

1 Like

created is not required.

@Simple_Development are you sure it’s resolved? I get this same error when sending the following parameter string as body of a post request:

symbol=LSKBTC&side=SELL&type=MARKET&timeInForce=GTC&quantity=38.01486137&newClientOrderId=e8bef040e26b4b927a15&newOrderRespType=FULL&recvWindow=5000&timeStamp=1623251547168&signature=04ef5e…

I have tried to reduce the commands to the required ones only, but no luck, I always get the error “Not all sent parameters were read; read ‘9’ parameter(s) but was sent ‘10’.” (replace 9 and 10 by n and n+1, depending on the number of parameters). What am I doing wrong? I have set the header Content-Type to application/x-www-form-urlencoded, API key is correct, checked all that more than once. The Rest API works for other commands, just /api/v3/order and /api/v3/order/test throw this error message. I would really like to know how to trade via API…

@docmanni, you’re sending timeStamp instead of timestamp. Plus, no need to send timeInForce for MARKET order.

1 Like