Convert API - signature not valid

Hi to all.
I started this topic new becuse it should be opened as other theme. Based on the last solution from NTSILI i have maneged to solve the problem regarding previous error. In the mean time i had the problem with time sync which i also solved but not thru code, rather with manual press on the “sync now” button under windows settings. So now am facing some other problem and i can not find solution whole day.

When i run the code and set 1000SATS as let’s say base currency that i want to track, Im sending the request for price check and as you can see i get correct values ( 1000SATS = 0 and USDC = 10 ) but then I get this signature error and i can not solve it. I have set new api key and secret, whitelisted few currencies, added my ip under restricted ones, but no changes. Any idea how to solve this ?

Error getting quote: {‘code’: -1022, ‘msg’: ‘Signature for this request is not valid.’}
1000SATS Current Price: None, Current Currency: USDC, USDC Balance: 10. 1000SATS Balance: 0

UPDATE:
I created one test program just for signature part and this is the answer:
Server time: 1720555211542
Timestamp: 1720555211542
Query string: fromAmount=0.01&fromAsset=BTC&timestamp=1720555211542&toAsset=USDT
Generated signature: ff123456789123456789123456789
Final params: {‘fromAsset’: ‘BTC’, ‘toAsset’: ‘USDT’, ‘fromAmount’: ‘0.01’, ‘timestamp’: 1720555211542, ‘signature’: ‘ff123456789123456789123456789’}
Response status code: 400
Response text: {“code”:-1022,“msg”:“Signature for this request is not valid.”}

Process finished with exit code 0

If you are having troubles generating a signature, please go through our examples in your desired programming language.

After some modification i finally got it working. Thank you for your suggestion and solution.
Best regards !