403 when posting

I am getting 403 error when I try to post in the category API spot / margin
By testing with this post, it seems I can’t paste my code example I wanted to talk about!

Here is a screenshot of the actual code example:

EDIT: clarification
I had an issue (issue 1) when fetching data from the API and to illustrate I wanted to put an example of code (image above)
When writing the post about issue 1, this site (dev.binance.vision) gave me a 403 Error (issue 2) forbidding me to post my issue 1 unless I removed the code example

Hi. May I clarify your question first?

You are facing issue with (1) API and you saw a 403 error when firing the request,
or (2) the forum and you saw a 403 error when trying to paste the code here?

I edited the initial post, is it clearer now?

Thanks for clarifying it.
Did you see any error message for the 1st issue? If so, what did it show?
For the second part, I can only say this is an authentication error so far. I’m not so sure what exactly triggered because a user has to login before writing.

Thanks for your reply. For issue 2 I tried to disconnect/reconnect and it doesn’t work.
I also get the issue 2 when I try to post here as a reply the text of issue 1

Below is the text of issue 1 without the code example:


I am using the python-binance library to call the Binance API.
However there is no build-in method to fetch the isolated margin transfers.
Hence, I tried to do it with private methods of the client class:

|code here|

The above code return indeed some transfers I made for the isolated pair ‘BTCBUSD’. However when I try the symbol 'KAVAUSDT ’ I get no transfer in return even so I traded this pair in isolated trading mid-2020.

TLDNR: I am able to fetch only the transfer history of some isolated symbols but not others, why is that?

I tried it once from my side with postman and it works fine for me. You can also check from your side too.

Probably there is something in your code, please check. Btw if your startTime is accidentally set as a future time, it will return empty data instead of an error message.

I tried on postman, I have the same behavior: I can fetch the transfers for some symbols (namely BTCBUSD, ENJBUSD) but I can’t get the transfers of KAVAUSDT because the list returned is empty.

I only use the symbol and startTime parameters. (for the time I used 1483228800000 or 2017/01/01)

So I really can’t figure that out.
Could it be because the KAVAUSDT transfers were made more than 6 month ago?

this site has protection, which may detect unallowed behaviour that leads to 403.
Please try to relogin or clean the cookie.

For API related question, please open another topic. thanks

Thanks dino for your reply. I cleaned the cookies and reloged but it did not change the issue.
In the end I just made a new topic without any code and I was able to publish it.